Yoga 720-15IKB (i5 version) Error occurred while loading the installer resources.
Started by Shanduur


Rate this topic
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5


2 posts in this topic
Shanduur
Junior Member
**


0
1 posts 1 threads Joined: Jul 2019
07-06-2019, 04:34 PM -
#1
So let’s start from beginning. I’m owner of Lenovo Yoga 720-15IKB (80X7), with:

* i5-7300HQ *CPU*
* Intel HD630 *iGPU*
* Intel HM175 *chipset*
* GTX 1050 2GB *(disabled)*
* Intel SSD NVMe 660p
* Dell DW1820A *(CN... version, working OOTB)*
* 8GB soldered RAM

I’ve found some configs to Yoga 720-15, but every is for i7-7700HQ version. I tried using [Vesavlad’s config](https://github.com/vesavlad/OS-X-LenovoYoga720), and some random configs from [TonyMacX86](https://www.tonymacx86.com/threads/yoga-...es.227222/), with no luck. I’ve found, that I’m not the only person that tried that, but the second person abandoned their attempt to get it working...

[My fork](https://github.com/Sheerley/OS-X-LenovoYoga720/) of Vesevlad's config, in which I tried to fix all problems.


**Here is what I’ve found:**

* with Vesavlad’s config I can boot to installer, create APFS partition. In stage 2, after 1st reboot I’m getting this [message](https://imgur.com/a/4yI1lMV).
* disabling Intel TPT does not allow me to get into installer. Nothing, just flashing black screen and back to clover and/or Windows 10 (according to boot settings). [This](https://imgur.com/gallery/SI7fGAs) is the verbose output. Last message is:

`VoodooPS2Trackpad sending final init sequence failed: 0`

* creating installer from MacOS 10.9 Mavericks works best for me. After making installer form Mojave, I was stuck on Prohibited sign. [Kernel Panic](https://imgur.com/gallery/WqDI9Oz) verbose output.

What should I do, to make it working? Is there really any huge difference between config for i5 and i7? Why am I unable to boot to installer with Intel TPT disabled?

May this be a problem connected to a Windows? I already have Win 10 installed on this machine (single SSD, 200MB EFI, 500GB W10, rest left for MacOS)?

**My BIOS settings:**

* Configuration
* Wireless LAN \[Enabled\]
* SATA Controller Mode \[AHCI\]
* Graphic Device \[Switchable Graphics\]
* Power Beep \[Disabled\]
* Intel Virtualization Technology \[Enabled\]
* Bios Back Flash \[Disabled\]
* Hotkey Mode \[Disabled\]
* Always On USB \[Enabled\]
* Thunderbolt ™ Device Boot Support \[Enabled\]
* Thermal Control \[Performance\]
* Security
* Intel Platform Trust Technology \[Enabled\]
* Intel SGX \[Disabled\]
* Secure Boot \[Disabled\]
* Boot
* Boot Mode \[UEFI\]
* Fast Boot \[Enabled\]
* USB Boot \[Enabled\]
* PXE Boot to LAN \[Disabled\]
* IPV4 PXE First \[Disabled\]


Sent from my iPhone using Tapatalk
Mark
hi my name is mark
*******


1
241 posts 8 threads Joined: Dec 2018
07-07-2019, 09:28 PM -
#2
Hey @Shanduur, looking at your EFI from GitHub, it looks like you have a lot of things that are installed that, well, shouldn't be installed. Remember, you're trying to get macOS installed first, not make it a perfect installation that's 100% stable (that comes later). You'll have to use an external mouse & keyboard in the meantime.

Only keep DSDT.aml in /EFI/CLOVER/ACPI/patched/; delete everything else for the meantime.

Add the boot argument "-wegnoegpu" to your config.plist.

The only things you should have in your /EFI/CLOVER/kexts/Other/ folder should be:
  • FakeSMC.kext
  • Lilu.kext
  • WhateverGreen.kext
  • GenericUSBXHCI.kext; and
  • USBInjectAll.kext
Delete everything in your /EFI/CLOVER/drivers64UEFI/ folder, reinstall Clover (use this link), and follow the options selected here:

[Image: attachment.php?aid=143]

Let me know what happens after doing all of this and we'll go from there.
hi guys welcome back to my roblox tutorial.
Mark
hi my name is mark
*******


1
241 posts 8 threads Joined: Dec 2018
07-07-2019, 09:31 PM -
#3
Also, update FakeSMC.kext, Lilu.kext, and WhateverGreen.kext.
hi guys welcome back to my roblox tutorial.


Forum Jump:


Users browsing this thread: 1 Guest(s)