Mark With Tech
Clover ➔ Apple logo ➔ stop sign - Printable Version

+- Mark With Tech (
+-- Forum: Hackintosh (
+--- Forum: Pre-Installation Help (
+---- Forum: macOS 10.14 Mojave (
+---- Thread: Clover ➔ Apple logo ➔ stop sign (/Thread-Clover-%E2%9E%94-Apple-logo-%E2%9E%94-stop-sign)

Pages: 1 2

Clover ➔ Apple logo ➔ stop sign - DePonor - 02-19-2019

Your guides make it all look like a piece of cake, but unfortuanely but I can't get it to work and have no idea why it is failing. If there is some debug/logging setting I can turn on in Clover, just let me know. I'd be grateful for any feedback that might help me.

I think I have accurately followed your video and written guide. Preparation of the USB loader goes well, starting the laptop with the USB loader displays the Clover screen, the Apple logo is displayed when the "install Mojave" option is chosen, the progress bar continues to about 55%-60% and then the Apple logo and progress bar are replaced by a stop sign. (Note: I am using the latest BIOS version, 1.06.00, before I updated to this the BIOS was v1.03.00 and a kernal panic happened around that 55-60% mark.)

I have tried a variety of tweaks to the BIOS settings but these produce the same result of everything hangs at the Apple logo stage (no progress bar appears).

I have tried starting afresh with a different USB stick, and some different Kexts. I still get the same.

I have a brand new laptop (received today) described by the SMBIOS option in Clover as:
  Intel Core i5-8250U @ 1.60GHz
  HP ProBook 450 G5
  with board 837D

The CPU is a KabyLake-refresh, the GPU an Intel 620 (there is no nVidia card or other second GPU).
- 256GB m.2 PCIe
- Samsung EVO 500GB SSD
RAM: 8GB DDR4 (1x module)

Windows 10 is pre-installed on the 256GB m.2. I have tried installing with and without this "disk" in the laptop.

I have tried changing the BIOS settings that were mentioned in general posts and this guide that should be for my type of laptop. Note:
- in the BIOS there is no option to enable/disable UEFI boot
- disable "Extended Idle Power States" seems to prevent Clover from even trying to load macOS.
- I have also tried "Virtualization Tech. (VTx)" enabled and "Virtualization Tech I/O (VTd)" disabled
- as well as  "Virtualization Tech. (VTx)" disabled and "Virtualization Tech I/O (VTd)" disabled

The attached ZIP file is a copy of the EFI folder on the USB stick. This is the one used the second time around following the guide for the HP laptops.

[Image: DFUVeME] [Image: SF0WWrM]

PS: It looks like the images are not displaying properly. But they didn't show much anyway. The screenshot after the kernel panic reboot shows messages like these:
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ApfsGptEntry is null
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess
(the lack of whitespace is as it appeared onscreen)

RE: Clover ➔ Apple logo ➔ stop sign - Mark - 02-19-2019

Hey @DePonor ,
You're missing GenericUSBXHCI.kext and USBInjectAll.kext. Something else you should also add is Lilu.kext and WhateverGreen.kext, as those will fix a lot of graphical issues (especially in laptops).

RE: Clover ➔ Apple logo ➔ stop sign - DePonor - 02-19-2019


I tried repeating the first attempt again (using one less Kext - one you used in the video but not in the written guide). There were two other differences:
- some of the BIOS settings (as detailed in the main post of this thread)
- the lack of a "disc" containing Windows

This time I got a lot further. It looked like it might be failing with some reboots, etc, but eventually I got the first setup screen of a MacOS installation. Woot! Unfortunately mye keyboard and mouse do npthing so I cannot continue.

Screenshot: [attachment=58]

Hey Mark,

I didn't see your reply until after I had posted my own reply. No offence meant, I was not ignoring your advice.

I have tried yet again. Like the last time, I am sticking as close as possible to your video and written guide. I have added some more Kexts (I had used them earlier, through I dropped one or two during my second attempt - which was the basis of the first post here - now I am back to your recommendations).

I get one step further, but that might be by accident. I no longer see the language selection screen, but instead I see a screen alternating between an image of a mouse and a keyboard. Nothing I do results in any change on screen, so it seems like my keyboard and mouse are being ignored.

I have the feeling that I am missing just a Kext file or two or a BIOS setting is not quite correct. I am running out of ideas and patience, and will probably leave this until the morning.

(Instead of uploading the whole EFI folder tree, I have just uploaded CLOVER/kexts/other as that is all that has changed apart from your (Mark's) config.plist. I have also added some screenshots of setting up the EFI where you can see that the options differ from Mark's guide.)

Clover ➔ Apple logo ➔ stop sign - Mark - 02-19-2019

What model of laptop is it? It might be I2C.

RE: Clover ➔ Apple logo ➔ stop sign - DePonor - 02-20-2019

It is a HP ProBook G5. The CPU is an 8th generation i5, it has integrated GPU (no dedicated/external GPU). The original "hard disc" has been removed (it contains Windows 10) and an SSD has been added. I don't know what I2C means or what its significance is.

There is good news and bad news.

The good news 1:
To get past the screen showing the keyboard and mouse images, I attached a USB mouse and a USB keyboard. The laptop's keyboard and trackpad are functional in the built-in setup menu and in Clover but they do not work during the installation of MacOS. This should help indicate what is missing but I cannot determine which Kext is missing or what BIOS setting is wrong.

The good news 2:
I was able to continue and install MacOS. All interaction was through the USB mouse and USB keyboard (the laptop's keybaord and trackpad were non-functional in MacOS).

The bad news 1:
I cannot reboot in MacOS or Clover without the USB drive inserted. This is against my expectation. I would expect to be able to boot directly into MacOS or at worst, into the Clover menu without having to insert a USB drive. Isn't there a way to have Clover on the SSD?

The bad news 2:
I cannot start MacOS. Using the USB drive, I can select the option "Boot macOS from SSD" in the Clover boot manager screen. This displays the Apple logo and progress bar but ends up rebooting the machine and returning me to the Clover screen again. I have tried some of the other options ("Boot Recovery from Recovery" and "Boot macOS Install Prebooter from Preboot") and these don't work either. The option "Boot macOS Install from install macOS Mojave" also fails (yes, I know I did this step earlier, but I tried to re-install macOS to see if that would help).

During booting the same error messages as mentioned in the first post are still displayed. Namely:
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: ApfsGptEntry is null
LegacyApfsContainerScan: Entrypoint
BlockSize: 512LegacyApfsContainerScan: Block device not supportedSuccess

The bottom line is: it is possible to run macOS on this laptop but it does not seem possible to reboot back into macOS - macOS can only be accessed at the end of the installation. In other words, it is unusable right now. But I have the feeling we're close to getting it working.

RE: Clover ➔ Apple logo ➔ stop sign - DePonor - 02-20-2019

I have no idea whether the symptoms described above are due to
  • a missing Kext file
  • a setting in a Kext file
  • a setting in the config.plist
  • a BIOS setting
But I hope that something in the description of the symtoms gives you an idea of what the cause could be.

I have tried using the Kext files you mentioned (GenericUSBXHCI.kext, USBInjectAll.kex, Lilu.kext and WhateverGreen.kext). That seems to have helped with the initial install of macOS, but as I pointed out above, I cannot get back into macOS.

I am including some screenshots from the BIOS settings. Please note that I have tried a variety of settings. The ones I am most suspicious about are:
"configure legacy support and secure boot" which has three options:
- legacy support enable and secure boot disable
- legacy support disable and secure boot enable
- legacy support disable and secure boot disable
and "configure option ROM policy" with options:
- all legacy
- all UEFI
- all UEFI except video
I have tried all three options for "configure legacy support and secure boot". Internet posts seems to imply that secure boot should be disabled, and I have tried both of the options (with and without legacy support). When legacy support is disabled, the choices for "configure option ROM policy" are also disabled and "all UEFI" is the fixed option. In this situation the "legacy boot order" is also disabled. (See screenshots)

I have read that "Virtualization Technology for Directed I/O (VTd)" needs to be disabled but is the same true for "Virtualization Technology (VTx)"?

Can you see something in the BIOS settings that could cause problems?

As for the laptop itself, the screenshots show some information in the BIOS. (I have added two screenshots.)

As I said earlier, the laptop is a HP ProBook 450 G5. The CPU is an 8th generation i5, it has an integrated GPU (no dedicated/external GPU). 

What else can I tell you about the laptop?

I'll add another question while I'm waiting ;-)   The prerequistes in the written guide for the installer mention Clover EFI (link) but it is not referenced later. The config.plist is, but does CLOVERX64.efi need to be downloaded? if so, where should it go? Does it belong in "EFI/CLOVER"? Or "EFI/CLOVER/drivers64"? (config.plist has been copied as instructed.)

RE: Clover ➔ Apple logo ➔ stop sign - DePonor - 02-20-2019

I have tried again to re-install macOS. From the boot menu I can select Clover (not as an option, but only by navigating to a file). Whatever option I choose (recovery, install, boot to macOS) makes no difference - the Apple logo appears, no progress bar, the system just hangs. This is very worrying. I think I should be able to overwrite what is on the SSD and re-install macOS. I have tried with an without legacy support (always with secure boot disabled). I have also tried with and without VTx and have tried after disabling the MS UEFI CA key. Is there some option in Clover I can make use of?

The screenshot shows the contents of the kexts/other folder of USB installer. (I re-ran Clover_v2.4k_r4877.pkg to make the EFI volume - the Mojave part was left as is.)

Clover ➔ Apple logo ➔ stop sign - Mark - 02-20-2019

Boot using verbose mode so we can see what's happening. To do this, hover over the Boot Prebooter from Preboot option, press the spacebar, tick the verbose option and select "Boot with selected options". Once the screen stops changing, take a picture and upload it.

When you're able to boot properly, we'll start worrying about other things (keyboard, mouse, etc.)

When you finally boot into macOS, you'll want to install Clover to your SSD so you can boot without the USB drive.

Sidenote: you want to increase your video memory to the maximum, in BIOS.

RE: Clover ➔ Apple logo ➔ stop sign - DePonor - 02-20-2019

Thanks for your reply, Mark, but unfortunately I cannot take that step. As I was totally stuck, I deleted the partitions on the SSD (I inserted the m.2 card containing Windows, used something called Diskpart to delete the partitions and removed the m2. card again). I tried re-installing (now following your video again) in verbose mode. But that hangs. I have changed some BIOS settings and retried again. And again. And again. And again. Always the same result. I am totally out of ideas (and energy).

Actually the only this I can think of is to delete the partitions again as they somehow get listed in the boot screen. But I really doubt that is going to help. And I don't know if I can even do something different. It seems like I cannot get the SSD back to a clean state.

(In the verbose screenshot, there should be a line at the bottom something like "--------------+", but it does not progress even after 10 or 15 minutes.)

Actually, I thought of one thing to try. In the Power Management Options I enabled Extended Idle Power States. The installation then goes further but then it continually complains about AppleUSBHostPort.

I will not be able to do anything for the next 60 hours as I will be away on business. I had hoped that this laptop would have been ready to take with me, but that was obviously way too optimistic. If you have any more ideas for me I'll try them from Saturday morning onwards.

RE: Clover ➔ Apple logo ➔ stop sign - DePonor - 02-23-2019

I have been trying again this morning. I reset the BIOS to the defaults and tried various settings. I run the installer in verbose mode and have tried single user and safe mode to see if that would help. I am not getting past the AppleUSBHostPort messages.